Does {TS} work?

Post Reply
Posts: 8
Joined: Sat May 05, 2012 7:35 pm

Does {TS} work?

Post by PathToEternity » Sat Jun 20, 2020 12:48 am

I'm trying to broaden my understanding of GINA and as an experiment I thought maybe I could use this tag to throw up a visual timer for the /pick command during the 5 minute wait period.

This is my search text:

Code: Select all

^You must wait 5 minutes between switching zones using /pickzone.  Remaining wait: {TS} seconds.
On the Timer tab I've selected Timer (Count Down) as the Timer Type, entered "/pick" as the Timer Name, and selected Restart current timer if Timer Name matches. I've tried this with Use Fast Check both marked and unmarked.

When I attempt this in game, I get two matches every time, and I get two copies of the timer for just a split second.
Gimagukk wrote:The tag will match the format D:H:M:S.L where D = days, H = hours, M = minutes, S = seconds, and L = fraction of second, and only the S (seconds) value is required.
This makes me think it should be parsing the TS value as seconds if there are no colons or decimals in the match, but to me it feels like it's parsing the match as fractions of a second, which is the only explanation I have for the timer disappearing so quickly. I don't have any explanation for the double match/timer.

At first I thought, maybe this requires at the very least a decimal to indicate seconds/fractions? But I can't think of really any game text that outputs that way, so that doesn't seem useful.

I've also tried a similar experiment with /camp and got the same results.

I think the {TS} tag was added towards the very end of active development, so I can't tell if I'm doing something wrong or if maybe it's just not implemented fully.

Posts: 62
Joined: Sun Aug 26, 2012 3:19 pm

Re: Does {TS} work?

Post by HSishi » Tue Jan 25, 2022 5:32 pm

I think the notation of the ingame waiting time is different from that what {TS} catches.

Do you have the full ingame text at hand?

Post Reply