GINA problem - stuck in "Connecting to Sharing Service..." w

Post Reply
Pumm
Posts: 3
Joined: Sun Feb 03, 2019 8:41 pm

GINA problem - stuck in "Connecting to Sharing Service..." w

Post by Pumm » Sun Feb 03, 2019 8:45 pm

Hey everyone,

For a while now I haven't been able to receive/merge any new GINA triggers, share any GINA triggers, or even access the shared window due to this problem:

The GINA Window gets stalled/stuck in "Connecting to Sharing Service..." whenever I try to "Merge" from someone who shared their triggers, trying to click into the Sharing tab Gimagukk's Library, or Share out using Quick Share.

See the Attached screen shot.

I've uninstalled GINA, and Reinstalled it, reset-up Pumm's log file paths, and changed the sharing functions around to see if that made any difference, and still nothing stops it from stalling out and getting stuck in this "Connectiong to Sharing Service..." overlay window.

Anyone have any ideas for a fix?
Attachments
GINA stuck in Connecting to Sharing Service....jpg
GINA stuck in Connecting to Sharing Service....jpg (98.4 KiB) Viewed 7697 times

Drakang
Posts: 7
Joined: Sat Dec 08, 2012 11:51 pm

Re: GINA problem - stuck in "Connecting to Sharing Service..

Post by Drakang » Sat Mar 16, 2019 10:43 pm

And more getting cannot connect to the sharing service.

Rrowzing
Posts: 14
Joined: Thu Nov 08, 2012 12:59 am

Re: GINA problem - stuck in "Connecting to Sharing Service..

Post by Rrowzing » Tue Mar 19, 2019 9:30 am

I think I have discovered the issue... your certificate is being reported as invalid.

So if I change
https://eq.gimasoft.com/GINAServices/Package.svc
to
http://eq.gimasoft.com/GINAServices/Package.svc

I can now access the sharing service (although not securely anymore.)

HSishi
Posts: 49
Joined: Sun Aug 26, 2012 3:19 pm

Re: GINA problem - stuck in "Connecting to Sharing Service..

Post by HSishi » Tue Mar 26, 2019 4:25 pm

Unfortunately that change reverts each time Gina is being started.

pryssylus
Posts: 1
Joined: Tue Apr 02, 2019 3:08 pm

Re: GINA problem - stuck in "Connecting to Sharing Service..

Post by pryssylus » Tue Apr 02, 2019 7:31 pm

I believe these are two distinct issues.

I've been fixing the certificate issue for a couple of weeks by using http instead of https. If you don't, you get a 'connection failed' message.

That's different from the issue being reported here, which involves the app hanging at 'connecting to sharing service' message.

My old PC worked fine, but I just moved to a new laptop, and this one exhibits the hang - and I'm using http in my sharing URL. In fact, when I add the 's' back in - now I don't see the connection failed message - it hangs at 'connecting' - which indicates this is occurring at a different stage in the process. Seems like this may be a firewall or port issue since I can't even get to the point where the certificate is checked.

Anyone have any ideas? Anyone have to modify defender firewall settings?

Post Reply